Speedometer broken

Off Topic Posts Welcome. Personal Attacks, Profanity or Obcenity will not be Tolerated.

Speedometer broken

Postby Lip Ripper » Thu Jan 11, 2018 5:38 am

Well on the first cruise in the Gal I noticed the odometer works but the speedo doesn't. Any idea's?
66 Cyclone GT; 245/60R15's on 15x8's and 215/70R15's on 15x7 Magnum's.
There's nothing like the sound of a pushrod V8 singing at the top of her lung's.
Lip Ripper
 
Posts: 1671
Joined: Wed Jun 06, 2012 4:47 am
Location: Lake Placid, Florida

Re: Speedometer broken

Postby poboyjo65 » Thu Jan 11, 2018 12:52 pm

Seems like I had one do that once, & the odometer still working, but my memory is fuzzy. it turned out to be the speedo cable wasn't pushed up in the speedo right,or all the way. I remember I was surprised that it started working after I fiddled with it,I thought for sure the speedo was broke. I cant remember what car it was other than I think it was a ford, & may have been a truck.
Image
347, 4sp, 9''
JOHNO
poboyjo65
 
Posts: 5011
Joined: Thu Oct 20, 2011 7:40 pm
Location: Camden, Tenn.

Re: Speedometer broken

Postby Groover » Thu Jan 11, 2018 2:24 pm

Many times, my speedo hasn't worked due to the cable not being pushed all the way in... in fact, just about every time I take the cluster out for some reason... but I've not really looked to see of the odometer is also not working.

I generally pull over when I notice no speedo, fiddle with the cable and it works again. As a rule, push the cable all the way into the speedo an let the trans end fall where it may.

But I would think if the speedo doesn't work, then the odo wouldn't work either. Aren't they driven the same way?
Image
1964 Comet Caliente Convertible
30,000 miles on our rebuild

All Comets start out as dreams...
User avatar
Groover
 
Posts: 1593
Joined: Wed Jun 02, 2010 9:36 pm
Location: Makanda, IL

Re: Speedometer broken

Postby Lip Ripper » Fri Jan 12, 2018 5:28 am

I'm trying to learn but I think the speedo is magnetic. It's hard to find any information on them.
66 Cyclone GT; 245/60R15's on 15x8's and 215/70R15's on 15x7 Magnum's.
There's nothing like the sound of a pushrod V8 singing at the top of her lung's.
Lip Ripper
 
Posts: 1671
Joined: Wed Jun 06, 2012 4:47 am
Location: Lake Placid, Florida

Re: Speedometer broken

Postby vicegrip » Fri Jan 12, 2018 8:27 am

OK...IIRC,the cable spins a magnet inside a steel drum connected to the needle which is spring loaded. The magnet doesn't actually touch the drum and the faster it spins,the more it grabs the drum,rotating it and the needle against the spring. Make any sense??? Anyway,IMO either the magnet fell off or the pivot point on the drum and needle has tightened up. I could have this turned around and the drum is on the cable and magnet on the needle but the problem would be the same.
On a side note,on it's maiden voyage,was backing my car out of the shop and happened to look at the speedo and it was spinning BACKWARDS! Back in the shop,tore it out and the drum and magnet were loaded with metal filings. Lesson learned...don't drill and grind under the dash with the speedo in the car.It was lucky I had a parts car with an extra speedo.
Good luck!
vicegrip
 
Posts: 228
Joined: Tue Jan 08, 2013 11:12 am

Re: Speedometer broken

Postby Lip Ripper » Fri Jan 12, 2018 1:01 pm

Well, I reached up and the collar was ever so slightly loose. Tightened maybe a 1/16 turn and boom baby, she works. And while cruising last night I turned the radio on so the light would fill the dash out. (radio wasn't working) Today I'm driving and thinkin what is that noise? I touched the volume on the radio and it works. Now the only thing I need to get working are the horns.
66 Cyclone GT; 245/60R15's on 15x8's and 215/70R15's on 15x7 Magnum's.
There's nothing like the sound of a pushrod V8 singing at the top of her lung's.
Lip Ripper
 
Posts: 1671
Joined: Wed Jun 06, 2012 4:47 am
Location: Lake Placid, Florida

Re: Speedometer broken

Postby Jims65cyclone » Fri Jan 12, 2018 4:24 pm

Hey, Lip, you need to start a business traveling around the country laying hands on guys sick rides and healing what's wrong with them. :lol: :lol:
Jim
Image

15x7x3.75BS TTII's all around
215/65/15 front, 235/60/15 rear
User avatar
Jims65cyclone
 
Posts: 1279
Joined: Sun Nov 23, 2014 9:29 pm
Location: Lexington, SC

Re: Speedometer broken

Postby loman » Fri Jan 12, 2018 5:36 pm

Lip Ripper wrote:Well, I reached up and the collar was ever so slightly loose. Tightened maybe a 1/16 turn and boom baby, she works. And while cruising last night I turned the radio on so the light would fill the dash out. (radio wasn't working) Today I'm driving and thinkin what is that noise? I touched the volume on the radio and it works. Now the only thing I need to get working are the horns.


Ha, behold the Miracle Worker. :lol:
User avatar
loman
 
Posts: 920
Joined: Sat Dec 28, 2013 8:03 am
Location: Missouri


Return to Comet Lounge

Who is online

Users browsing this forum: No registered users and 1 guest