Lost all electrical power

289 - 351 cid Small Block Performance

Lost all electrical power

Postby thrnelson » Sat Jul 09, 2016 8:44 pm

I just got the replacement rack and pinion installed for the defective one I had and installed a brand new ididit steering column. The car drove great. I got the family all in the car to go to dinner, pulled it out of the garage and lost all electrical power. I mean all no lights no click no anything. I checked voltage at the battery and it is full. Does anybody have any ideas? Everytime I get close to being able to drive it something else happens. Please help!
Image
thrnelson
 
Posts: 73
Joined: Thu Sep 10, 2015 11:58 am
Location: Binghamton, NY

Re: Lost all electrical power

Postby poboyjo65 » Sat Jul 09, 2016 9:14 pm

Check ground battery to block.
Image
347, 4sp, 9''......
JOHNO
poboyjo65
 
Posts: 4453
Joined: Thu Oct 20, 2011 7:40 pm
Location: Camden, Tenn.

Re: Lost all electrical power

Postby thrnelson » Sat Jul 09, 2016 9:28 pm

Thanks. I kept looking at the positive side. I just checked and the negative side on the battery was a little loose. It started again. I can now go to sleep. Comet central comes through again.
Image
thrnelson
 
Posts: 73
Joined: Thu Sep 10, 2015 11:58 am
Location: Binghamton, NY

Re: Lost all electrical power

Postby poboyjo65 » Sat Jul 09, 2016 9:33 pm

Your welcome. glad it was something easy. :D
Image
347, 4sp, 9''......
JOHNO
poboyjo65
 
Posts: 4453
Joined: Thu Oct 20, 2011 7:40 pm
Location: Camden, Tenn.

Re: Lost all electrical power

Postby CALIFORNIA CALIENTE » Sun Jul 10, 2016 12:36 am

ALWAYS check the ground on EVERYTHING!!It can be a BIG issue that nobody seems to want to deal with!! JMO , ROY.
Real Racecars have 3 pedals
Image
CALIFORNIA CALIENTE
 
Posts: 5933
Joined: Sun Feb 19, 2006 11:57 pm
Location: Camarillo,California


Return to Small Block V-8 Performance

Who is online

Users browsing this forum: No registered users and 1 guest