Page 1 of 1

HEI Distributor not working

Posted: Thu May 21, 2020 12:31 pm
by GeneB
63 Comet with 302 engine. Got car 2 years ago & ir ran fine until last week. Been sitting since last month . Went to move it out of garage so I could install new garage door. Started right up then died after about 30 sec. No Spark.
Got a chance to work on it Sunday
Power to bat terminal
wiggled all wires no help
pushed it back into garage (Didn't try to start it)
next day it started right up and ran for 5 minutes then I turned it off
Next day no start again
Checked coil & pickup with ohm meter. All readings OK
Bought new rotor, cap, module. No start
When I checked power to Dist I used a test probe. Checked voltage with meter got 10.5 volts with key on, 9.5 while cranking.
Got new coil this morning and no change
Checked current to Dist and it draws 2 amps with key on
Checked wiring to dist & no shorts to ground
What would cause it to draw this much current? everything new but pickup and it checked OK with meter

Re: HEI Distributor not working

Posted: Thu May 21, 2020 8:20 pm
by tomb22
Try checking out the switch. Contacts could be bad.
tom

Re: HEI Distributor not working

Posted: Thu May 21, 2020 8:41 pm
by GeneB
Which switch should I check

Re: HEI Distributor not working

Posted: Fri May 22, 2020 8:25 am
by GeneB
Problem Solved
I had my Tach out and tach wire under dash was touching ground.
Stupid mistake cost me $100 in not needed parts.

I can get Comet out of garage now and hook up garage door opener. Wife will be happy